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1 概述 

1.1 系统简介 

核数据处理绘图客户端软件 NDPlot 是一个集成化的核数据处理、

绘图软件，具备专业绘图和专业核数据处理的能力。采用了面向对象

的程序设计，支持多文档接口（MDI），可以多窗口显示、处理数据。

采用了所见即所得的界面显示，并支持 Windows 剪贴板。NDPlot 的

图形用户接口（GUI）采用的是跨平台的 WxWidgets。在核数据处理

方面，可以完成核反应截面数据、角分布数据、能谱数据、双微分谱

数据、裂变中子数数据、裂变产额数据、放射性核素产生截面数据、

反应截面协方差数据的标准差等，还包括曲线求比、曲线求和、曲线

拟合、卡方计算、原始数据追溯、自由格式数据导入、批量处理、实

验数据挑选等分析挖掘工具。在图形处理方面，支持坐标系风格、坐

标系尺寸、图注风格、图注的显示和隐藏、文本字体、颜色、线型、

数据点图形、数据点尺寸、曲线误差带的显示和隐藏，绘图顺序（决

定谁在最上层）等的调整，还包括曲线或者数据点的反显、突出显示、

局部图形显示、矢量图形输出等功能。支持 All-in-One 的工程文件，

所有的信息都存储在一个文件中。在任何一个机器上用 NDPLot 打开

都能显示一样的结果，十分方便用户的数据共用，目前国际上其它的

此类核数据软件系统均没有此功能。 

1.2 系统运行环境 

 NDPLot 客户端可以运行在 Windows 系列的操作系统，包括： 

Windows7、Widnows8、Windows10、Windows11、Windows Server

等 64 位系统。 

1.3 版权说明 

NDPlot 软件版权和著作权归属于中国原子能科学研究院、中国

核数据中心。 
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2 软件使用说明 

2.1 软件的安装和卸载 

NDPlot 客户端以 MSI 安装包的形式发行，在 Windows 系统下可

以直接双击安装或者卸载。也可以使用 Windows 的软件管理进行卸载。 

 

图 1. 软件安装界面 

2.2 软件的启动和注册 

安装完成后从 Windows 程序菜单或者桌面的快捷方式都可以启

动 NDPlot 客户端，也可以通过双击 NDPlot 的工程文件（.ND，.NDS）

或者数据文件（.NDD）来启动 NDPLot 客户端。相应的工程文件或者

数据文件会被自动加载。 

首次运行需要在线注册，注册的目的是为了在服务器端防止资源

冲突，区分不同用户的计算结果。 
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图 2. 注册 

 
图 3. 登录 

启动之后，用 File->new（Ctrl+N）新建一个窗口。 
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图 4. 新建一个窗口 

2.3 软件的界面介绍 

NDPlot 客户端软件有一个主窗口，主窗口有一个菜单栏，一个

或者多个子窗口，每个子窗口含有一个控制板和画布。画布显示坐标

系和图注等。 

 

图 5. 软件主窗口 

控制板展开后如下： 
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图 6. 子窗口控制板 

 

图 7. 多窗口显示 

2.4 软件的绘图刷新和控制板展开（重要提示） 

大多数情况下，软件的绘图需要手动刷新，这是因为，对于存在

共振区的大量数据，自动刷新会造成软件反应缓慢。如果发现操作后

绘图没有变化，请使用菜单 Edit->Force to Refresh(F5)强制刷新，

或者控制板的 Refresh 按钮强制刷新。 
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图 8. 手动刷新 

控制板展开按钮位置不太显眼，位于窗口左侧： 

 
图 9. 控制板展开/收缩按钮 

2.5 Windows 用户名为中文的用户的注意事项 

 许多跨平台的编程语言内部是用的是 UTF-8 编码，而 Windows 采

用的是 ANSI 编码，在路径上使用非英文字符（非 ASCII）可能会产

生问题，NDPlot 需要使用 Windows 的 TEMP 目录，通常位于用户目录

下，如果用户名为中文，可能不能正确解析。可以修改中文用户名的

系统的 temp、tmp 目录。方法：我的电脑（win10 为此电脑）右键-》
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属性-》高级设置 
 

 

图 10. 修改 TMP、TEMP 默认路径 

3 评价数据处理和绘图 

路径：菜单 Data->Connect to Evaluated Lib（快捷键 Alt+E） 

3.1 评价数据核反应截面、角分布、能谱、双微分截面绘图 

 

图 11. 选择评价库 
对于截面，Ei(入射能量）和 Angle 会被自动略去（是否填写不影

响），同样，对于角分布，Angle 会被自动略去。 
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MT=9000相当于(n，x)，对于(n，x)的中子出射双微分截面，MF=6，

MT=9000，ZAOUT=1。如 Ta-181(n,x)0-n-1,DAE,14Mev,30 度角的双微

分截面，对应如下： 

 

图 12. 选择三家评价库 Ta-181 的总中子谱 

 

图 13. Ta-181(n,x)0-n-1, En=14.1MeV，30 度角的总中子出射谱 

3.2 评价数据裂变中子数绘图 

裂变中子数、瞬发和缓发裂变中子数的 MF=1，MT 分别为（452，

455，456）。 
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图 14. U-235(n,F)裂变中子数 MT=452 

 
图 15.添加实验数据 
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图 16. U-235(n,F)裂变中子数绘图结果 

4 实验数据 EXFOR 处理和绘图 

路径：菜单 Data->Connect to EXFOR Lib（快捷键 Alt+X）。 

4.1 实验数据截面绘图 

例如，检索 Ta-181(n，2n)TA-180 反应: 

 
图 17. 检索 Ta-181(n,2n)Ta-180 
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图 18. 选择 73-Ta-181(n,2n)73-Ta-180,,SIG 反应式 

 

图 19. 73-Ta-181(n,2n)73-Ta-180 加上评价数据的绘图结果 
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4.2 检索 EXFOR 数据使用过滤器 

 
图 20. U-235(n,f) 

结果如下： 

 
图 21. U-235(n,f)检索结果 

一共有 188 个反应 CODE 分类，可以使用 Filter 来过滤表达式： 

如用：“^(92-U-238”来过滤出以“(92-U-238”开头的表达式，

^表示开头，$表示结尾（如“,SIG$”）. 

结果如下： 
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图 22. U-235(n,f)检索结果使用过滤器 

很容易找到 u238/u235 的数据： 

如我们选择：((92-U-238(N,F),,SIG)/(92-U-235(N,F),,SIG))，点击 Choice

标题可以把选择的排列到一起。 

 
图 23. 对检索结果进行排序 

4.3 实验数据角分布、能谱、双微分截面绘图 

例如，检索 Ta-181(n,x)反应的总中子双微分截面，Quantity=DAE。 
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图 24. Ta-181(n,x),DAE 反应 
 

 
图 25. 选择 73-Ta-181(n,x)0-NN-1,,DA/DE 反应式 

检索的实验数据按照能量和角度分类 



15 
核数据处理绘图客户端软件 NDPlot V0.98b 

 

图 26.选择 14.1MeV，90 度角 

 

图 27. 73-Ta-181(n,x)0-NN-1,,DA/DE 绘图 
 

如前所述，加入评价数据比对： 
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图 28. 73-Ta-181(n,x)0-NN-1,,DA/DE 评价数据和实验数据绘图 

5 批量绘图功能和自动乘以因子区分数据 

路径：菜单 Batch Plotting(Alt+B) 

对于能谱、角分布、双微分截面等多个能量和角度的绘图十分方

便，支持不同能量和角度数据乘以系数以方便的将其绘制到一张图上。 

通常，需要画什么数据是由实验数据决定的，可以先检索实验数

据： 
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图 29. 挑选实验数据 

以 Ta-181(n,el)DA 为例，检索实验数据： 

 

图 30. Ta-181(n,el)DA 检索结果 
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我们选择 14.X 的入射能量，批命令自动填入，可以选择所有数

据绘制在一个画布上，乘以一个因子（0.01）来区分不同能量的数据。

（第一组数据*1，第二组数据*0.01，第三组数据*（0.01*0.01），以

此类推） 

 
图 31. 设定因子以在图形上拉开间距 

   得到如下结果：
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图 32. 绘图结果 

如果不选所有数据绘制到一个窗口上（all data be plotted in 

one window）,可以得到一个多窗口的结果。 
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图 33. 绘制在不同窗口中 

6 截面比值处理和绘图 

6.1 截面比值实验数据 

路径：菜单 Data->Connect to EXFOR Lib（快捷键 Alt+X） 

 
图 34. 检索实验数据库 
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结果如下： 

 
图 35. U-235(n,f)截面数据检索结果 

检索结果一共有 188 个反应表达式（CODE）的分类，可以使用过

滤器（Filter）来过滤表达式： 

如用：“^(92-U-238 ”来过滤出以“(92-U-238”开头的表达式，

^表示开头，$表示结尾（如“，SIG$”）. 

结果如下： 
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图 36. 使用过滤器减少反应表达式 

很容易找到 u238/u235 的数据： 

如我们选择比值数据：

((92-U-238(N,F),,SIG)/(92-U-235(N,F),,SIG))，点击 Choice 标题

可以把已选择的排序到一起。 

 

图 37. (92-U-238(N,F),,SIG)/(92-U-235(N,F),,SIG 比值 
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图 38. 对选中的实验进行数据绘图 

6.2 截面比值评价数据 

如前所述的比值实验数据，我们加入评价数据比值： 

路径：菜单->Data->Ratio of Evaluated Data 

 

图 39.选择比值评价数据 
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图 40. 加入评价数据的比值绘图 

7 支持批量的曲线求比 

菜单：data-》Ratio with Curves 

 
图 41. 曲线求比菜单 
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图 42.  曲线求比设置分母 

 

for all Windows 复选框：支持所有窗口执行比值运算功能 

Create new canvas 复选框：比值运算结果放到新建的窗口中 

All ratios are in one Window 复选框：所有比值运算结果放

到同一个新建的窗口中（Create new canvas 复选框失效） 

Percent(%)复选框：以百分数形式显示 

Key of legend for Denominator：分母的图注，如果为空，取

上面选中的分母的 TITLE：ENDFB8.0。 

如果多个窗口中的图题形式加了其他字符，如 ENDFB8.0(n,2n)，

ENDFB8.0(n,3n)，在此填入 ENDF(子集即可)就可以用 ENDFB8.0 来做

分母。 
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7.1 新建窗口的求比操作 

 

 
图 43.  选择新建窗口 

得到如下结果： 
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图 44.  结果绘图 

增加了三个比值结果窗口： 

7.2 不建新窗口的求比操作(双坐标系) 

 
图 45.  选择不建新窗口 

得到如下结果，每个窗口新增一个比值坐标系： 

 
图 46.  结果 
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7.3 调整双坐标系的大小、位置、间距 

调整坐标系大小（点圆形区域，可拉动 8 个黑方框）： 

 

图 47.  调整双坐标系的大小和位置 

去掉主轴坐标值（双击方形区域，进入坐标系设置，见下图）： 

 
图 48.  加水平网格 

加网格，把横坐标的标题（En，MeV）拉到比值坐标系下方，结
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果如下： 

 
图 49.  去除主坐标系横坐标刻度、加入水平网格 

调整主坐标系和比值坐标系的间距： 

路径：AXIS-》Set up ratio axis 

 

图 50.  调整双坐标系间距 
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图 51.  减少双坐标系间距 

7.4 对其它窗口以当前窗口批量调整坐标系的尺寸和位置 
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图 52.  菜单 
 

结果如下： 

 
图 53.结果 

包括双坐标系位置，横坐标的标题位置，比值坐标系的纵坐标的

标题，都会同步成完全一样。 

7.5 所有比值绘制到一张图中 

 

图 54.所有比值绘制到一张图中 
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图 55.结果绘图 

查看比值的计算数据（单坐标系的比值窗口都可以看）： 

 

图 56.查看比值数据 
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8 曲线求和及工程文件复用 

8.1 曲线求和 

NDPlot 客户端可以对曲线进行求和，会自动完成曲线的插值，

如图： 

Ta-181，MT=（51-62,91）的检索和绘图，Ta-181 的 MT=4 的检

索和绘图。 

 
图 57. Ta-181(mt=50-91)  

我们对（Mt=51-62，MT=91）进行求和，求和结果是与 MT=4 重合

的，说明数据是正确的。 
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图 58. Ta-181(mt=50-91 求和)  

 

8.2 向工程文件 NDS 批量添加曲线 

路径：菜单->Add Curves to project from ENDF file. 

NDPLot 会对每个窗口维护一个反应列表，利用此功能可方便的

向对应的窗口添加曲线（需要先保存工程文件 NDS）。 

如以下工程文件包含了(3,1)、(3,16)、(6,9000,14Mev,30 度角)

的数据。 
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图 59.已有工程文件  

使用如下菜单（快捷键 Alt+A）： 

 

图 60.菜单项 

我们从服务器上增加 ENDF/B7.1,并添加一个本地 PEN 文件： 
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图 61.选择评价库和本地文件 

结果如下： 

 
图 62.绘图结果 

反应列表可以编辑，也可以带系数（相乘），可用于多种用途。 
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下面我们把铅的天然核素的丰度作为系数来加工天然铅的弹性

截面数据。 

 
图 63. 向工程文件中添加反应列表 

再利用曲线求和： 

 

图 64. 曲线求和 
 

检索天然铅的弹性截面实验数据： 
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图 65. 检索天然铅的弹性截面实验数据 

我们得到： 

图 66.天然铅的弹性截面评价数据和实验数据 
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9 总谱分谱的比对绘图 

如 U-238（n,x）的 14.05Mev,30 度的总中子出射谱和分谱： 

在批绘图中填入： 

6;9000;14.05;30;;1; 

6;2;14.05;30;;1; 

6;16;14.05;30;;1; 

6;17;14.05;30;;1; 

6;18;14.05;30;;1; 

6;51-91;14.05;30;;1; 

连续的 mt 可以写成 51-91 这种形式 

 

 

图 67. 批绘图中填入谱的 mf，mt 等 

可以选择：不使用实验数据，画在一张图上，图题加 reaction 

结果： 
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图 68. 总谱和分谱的绘图结果 

 

对分谱求和：与总谱结果一致。 

 
图 69. 分谱求和（Sum） 

10 截面协方差数据的标准差的误差带显示 

菜单：Error Band->relative Error 或者 Error Band->relative 

Error（new canvas） 
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Error Band 菜单还包括了显示/隐藏误差带，为了解决误差带的

覆盖问题，可依次显示误差带。 

 
图 70. 显示误差带 

 
 

 
图 71. 比值双坐标系中显示截面标准差误差带 



42 
核数据处理绘图客户端软件 NDPlot V0.98b 

11 放射性核素产生截面 

 
图 72. 放射性核素产生截面菜单 

 

图 73. 加工本地 PENDF 文件 
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图 74. 得到的产物列表 

 
图 75. 全选绘图 

 

曲线的标注不准确，请参看剩余核，如（p，n）应为（p，xn） 



44 
核数据处理绘图客户端软件 NDPlot V0.98b 

 
图 76.从数据库中选择 

 
图 77.产物 Br-77 的基态和激发态截面数据 

12 链产额和产额能量关系处理和绘图 

12.1 链产额 

从实验数据库中获取数据，选择 Yield Chain： 
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图 78. U-235 链产额实验数据检索 

可以使用过滤器减少反应式的数量： 

 
图 79. 使用过滤器 

选择热能点： 
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图 80. 选择能点 

得到绘图数据： 

 

图 81. 绘图 
 

从菜单 data->Chain Yield（Evaluated）检索评价数据，热能

点 
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图 82. U-235 链产额评价数据检索 

 

图 83. U-235 选择热能点 
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结果如下： 

 

图 84. U-235 绘图结果 
 

局部显示： 

 

图 85. U-235 绘图结果局部显示 
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注意一些实验数据没有量纲，如：需要用户自己决定如何使用这

些数据。 

 

12.2 用累积产额实验数据加工链产额数据 

实验库中，链产额数据较少，可以使用较多的累积产额数据产生

链产额数据： 

如：92-U-235(N,F)ELEM/MASS,CUM,FY  

 
图 86. 检索 U-235 累积产额 

我们得到如下结果： 
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图 87. U-235 累积产额绘图 

通过 data->manipulating data 菜单，进入某一个实验的数据和

原始数据（Data&Original），我们得到数据网格和原始数据窗口： 

 
图 88. 挑选数据 

 

通过挑选数据按钮（Select Data），我们得到如下窗口： 
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图 89. 依据评价库过滤数据 
 

我们可以手工选择数据作为链产额数据，或者依据 ENDF/B8 来选

择： 

100%，99%，97%，95%意思是产物的产额大于 ENDF/B8 链产额的

100%，99%，97%，95%，这个产物的数据就可以作为链产额。 

12.3 链产额实验数据的 gamma 修正 

产额的数据通常是通过衰变数据的 gamma 数据来计算出来的，如

果 gamma 数据产生了变化，产额数据通常也需要修正。NDPlot 提供

了一个简化的算法修正产额数据。如上图的 Gamma Correction按钮。

我们进入 gamma 修正窗口： 

 

图 90. 利用 gamma 数据修正产额数据 
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如果 NDPlot 自带的 gamma 数据（gamma2018_simple.xml，数据

来自 NNDC）和实验数据库的 gamma 数据不同），我们按下 Correct 按

钮，已经修正的数据会以红色底色显示。用户自己的新 gamma 数据也

可以手工填入上表中，或者编辑 gamma2018_simple.xml。 

简化的修正公式如下： 

FYcorrected=1/( Max(Intensityexfor)/ Intensitynew)*FY  

12.4 产额能量关系 

    检索实验数据库： 

 
图 91. 检索产额能量关系实验数据 

 
图 92. 检索结果 

选择 Mo-99： 
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图 93. 选择 Mo-99 

选择评价数据（data->Yield Energy Dependence）： 

 
图 94. 添加评价数据 
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图 95. 产额能量关系绘图结果 

13 瞬发中子谱实验数据获取 

从实验数据中检索中子谱数据 

 
图 96.检索 U-235 中子谱数据 
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图 97. 筛选数据 

 
图 98.按能点给出数据 

 
图 99. 得到的结果 
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14 缓发中子谱评价数据绘图 

可以从评价库或者本机的评价数据得到中子谱的绘图数据。 

 
图 100. 评价库和本地 PENDF 文件 

 
图 101. 缓发中子谱绘图 
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15 带权重的 χ2计算 

为了定量的分析评价数据的质量，以实验数据以依据，进行 χ2

计算，对于多家实验数据，可以给出权重。 

χ2公式如下， 

             ∑∑
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其中：Wt为总实验点数的权重之和；σth、σexp和 σerr分别为截

面理论值、实验测量值及实验测量值的误差，Wi为第 i 家实验数的权

重。 

路径：Error Band-》Chi square for experimental data and 

curves。 

 
图 102. Y-89(n,2n)各家评价数据的χ2计算 

16 利用曲线求固定能点或角度的数值 

在实际使用数据的过程中，常常需要固定能点或者角度的插值。 
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路径：Data-》Interpolation 

如对 Ta-181（n,el）的 Ei=14MeV 角分布数据，求 10-180 度的

数值: 

 

图 103. Ta-181（n,el）的 Ei=14MeV角分布数据 

 

图 104. Ta-181（n,el）的 Ei=14MeV插值结果 
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对于角分布数据，使用 Cosine 插值更准确一些（Degree to 

Cosine）。

 
图 105. 使用 cosine的插值结果 

17 自由格式数据导入 

路径：DATA-》Import Text Data 

选择数据类型： 

 
图 106. 选择数据类型（评价曲线或者实验数据点） 

从剪贴板贴入数据或者从文件读入： 
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图 107. 剪贴板贴入数据或者从文件读入 

对于单组数据，可以直接将用空格或者逗号等分隔符分隔的数据

导入如： 

1 0.5 

2 0.7 

3 0.8 

… 

对于多组数据，可以用!、!!、!#等控制字符： 

！！：本行及之后的数据丢弃 

！：下一行是数据 

!#:标题(非必须，但可以提示每列对应的数据) 

可以直接在编辑器里修改，也可以在原始文件里修改。 

例如导入 EXFOR 数据，可以加入控制字符去除干扰： 
!!SUBENT        20416016   20170228   20170614   20170613       2259 

BIB                  5         17 

REACTION   (73-TA-181(N,2N)73-TA-180,,SIG) 

MONIT-REF  (,M.G.Sowerby+,R,AERE-R-72/73,1973) 

ERR-ANALYS (DATA-ERR) Errors given are standard errors derived by 

            quadratic addition of the statistical errors of the 

            experimental data and the errors of the correction. 

           .Uncertainties of Cf-252(NU-BAR) and U-238-fission 

            cross-sections are not included. 

ENDBIB              17 

NOCOMMON             0          0 

DATA                 5         14 

!#EN        EN-RSL-HW  MONIT      DATA       DATA-ERR 

!MEV        MEV        MB         MB         MB 

       8.44      0.135       962.       271.        28. 

       8.94      0.125       964.       709.        47. 

       9.44      0.115       960.      1217.       112. 

       9.93      0.110       952.      1372.        83. 

      10.42      0.110       948.      1518.        93. 

      10.91      0.095       952.      1581.       110. 

      11.40      0.090       957.      1653.       102. 

      11.88      0.085       965.      1778.       101. 
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      12.36      0.085       978.      1845.       111. 

      12.85      0.080       999.      1935.       117. 

      13.33      0.075      1031.      1891.       119. 

      13.80      0.075      1086.      1920.       118. 

      14.28      0.070      1163.      1900.       153. 

      14.76      0.065      1216.      1856.       159. 

!!ENDDATA             16 

ENDSUBENT           38 

 

图 108. 加入控制字符 

根据需要选择相应的分隔符： 

 

图 109. 分隔符选空格 

选择数据列的定义（Discard 为丢弃）： 
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图 110. 选择数据列的定义 

 

图 111. 导入的结果 

如需要调整量纲，可以用列操作来实现（见数据的列操作）。多

组数据常用的导入格式如下： 
! 

!#CENDL3.2 

8.050000e+000 5.362500e-002 0.000000e+000 

8.500000e+000 3.630400e-001 0.000000e+000 

9.000000e+000 8.357500e-001 0.000000e+000 

9.500000e+000 1.209500e+000 0.000000e+000 
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1.000000e+001 1.414700e+000 0.000000e+000 

1.050000e+001 1.536300e+000 0.000000e+000 

1.100100e+001 1.621100e+000 0.000000e+000 

1.116000e+001 1.650700e+000 0.000000e+000 

1.150000e+001 1.719900e+000 0.000000e+000 

1.200000e+001 1.808500e+000 0.000000e+000 

1.250000e+001 1.876300e+000 0.000000e+000 

1.300000e+001 1.931500e+000 0.000000e+000 

1.400000e+001 2.013700e+000 0.000000e+000 

1.460000e+001 2.031600e+000 0.000000e+000 

1.500000e+001 2.021800e+000 0.000000e+000 

1.600000e+001 1.900600e+000 0.000000e+000 

1.800000e+001 1.275300e+000 0.000000e+000 

2.000000e+001 7.077500e-001 0.000000e+000 

! 

!#ENDFB8.0 

7.800000e+000 1.543500e-002 0.000000e+000 

8.000000e+000 9.467200e-002 0.000000e+000 

8.200000e+000 2.486600e-001 0.000000e+000 

8.400000e+000 4.451500e-001 0.000000e+000 

8.600000e+000 6.526800e-001 0.000000e+000 

8.800000e+000 8.529600e-001 0.000000e+000 

9.000000e+000 1.035400e+000 0.000000e+000 

9.200000e+000 1.195400e+000 0.000000e+000 

9.400000e+000 1.334500e+000 0.000000e+000 

9.600000e+000 1.453000e+000 0.000000e+000 

9.800000e+000 1.553800e+000 0.000000e+000 

1.000000e+001 1.639300e+000 0.000000e+000 

1.020000e+001 1.709000e+000 0.000000e+000 

1.040000e+001 1.769500e+000 0.000000e+000 

1.060000e+001 1.819500e+000 0.000000e+000 

1.080000e+001 1.861000e+000 0.000000e+000 

1.100000e+001 1.896700e+000 0.000000e+000 

1.140000e+001 1.951400e+000 0.000000e+000 

1.180000e+001 1.990000e+000 0.000000e+000 

1.220000e+001 2.017700e+000 0.000000e+000 

1.280000e+001 2.047500e+000 0.000000e+000 

1.360000e+001 2.073200e+000 0.000000e+000 

1.440000e+001 2.089700e+000 0.000000e+000 

1.460000e+001 2.090900e+000 0.000000e+000 

1.480000e+001 2.088200e+000 0.000000e+000 

1.500000e+001 2.079800e+000 0.000000e+000 

1.520000e+001 2.061600e+000 0.000000e+000 

1.540000e+001 2.034500e+000 0.000000e+000 

1.560000e+001 1.996900e+000 0.000000e+000 

1.580000e+001 1.951000e+000 0.000000e+000 

1.600000e+001 1.898700e+000 0.000000e+000 

1.620000e+001 1.840500e+000 0.000000e+000 

1.640000e+001 1.777700e+000 0.000000e+000 

1.700000e+001 1.575600e+000 0.000000e+000 

1.720000e+001 1.506700e+000 0.000000e+000 

1.760000e+001 1.373900e+000 0.000000e+000 

1.800000e+001 1.248800e+000 0.000000e+000 

1.840000e+001 1.132700e+000 0.000000e+000 

1.880000e+001 1.027800e+000 0.000000e+000 

1.900000e+001 9.786700e-001 0.000000e+000 

1.940000e+001 8.885000e-001 0.000000e+000 

1.960000e+001 8.474900e-001 0.000000e+000 
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1.980000e+001 8.086100e-001 0.000000e+000 

2.000000e+001 7.776400e-001 0.000000e+000 

18 利用 Windows 剪贴板复制实验信息、绘图图形和数据 

18.1 EXFOR 实验信息报表 

检索实验数据，并进行选择后，点击“Copy to Clipboard”,

可将 EXFOR 信息复制到剪贴板，并可以粘贴到 EXCEL 等其它软件中： 

 
图 112. 对检索结果进行信息报表 

 

图 113. 从实验信息从剪贴板粘贴到 EXCEL 中 
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18.2 获取图形到剪贴板 

路径：菜单->Edit->Copy Graph to ClipBoard(快捷键 Ctrl+C) 

当前子窗口的图形会被复制到剪贴板，可以方便的贴到 word、

ppt 等文件中。 

18.3 获取绘图数据到剪贴板 

路径：菜单->Edit->Copy Exp data to ClipBoard(实验数据) 

路径：菜单->Edit->Copy Eva data to ClipBoard(评价数据) 

 
图 114.将实验数据复制到剪贴板中 

19 窗口的保存 

19.1 保存当前子窗口的工程文件（.ND） 

路径：菜单->File->Save  

所有当前窗口的数据、风格、注释等元素将被保存。 

通过菜单->File->Open 或者双击 ND 文件可打开。 
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19.2 保存所有窗口的工程文件（.NDS） 

路径：菜单->File->Save Project 

所有窗口的数据、风格、注释等元素将被保存。 

通过菜单->File->Open Project 或者双击 NDS 文件可打开。 

20 数据的追溯和列操作 

20.1 查看原始数据 

20.1.1 通过 Data 菜单查看原始数据 

路径：菜单->File->Data Manipulating（Alt+D） 

 
图 115. 双击查看原始数据 

双击按钮可查看绘图数据和原始数据。 

EXFOR 数据： 
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图 116. EXFOR 原始数据 

ENDF 数据： 

 
图 117.ENDF 原始数据 
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20.1.2 通过 Quick Choice 菜单查看原始数据 

 
图 118. Quick Choice 窗口 

双击红色区域可显示“Data&Original Data”。 
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20.1.3 在画布上鼠标选中数据点，右键查看原始数据 

 
图 119. 画布上鼠标选中数据点，右键查看原始数据 

20.2 数据的列操作 

 “Data&Original Data”窗口既可以查看原始数据，也可以通

过左边的数据表格操作数据，可以直接修改，也可以通过列操作单元

格(Col. Oper.)来进行列操作。 
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20.2.1 利用列操作将角度转换成 cosine 值 

 

图 120. 要进行列操作的数据 
 

如对 A 列的数据是角度，转换换成 COSINE 值，通过公式

cos(deg2rad([a]))来实现： 
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图 121. 角度转换成 COSINE 

20.2.2 利用列操作修改数据点误差 

如将误差设置成 3%，只需对[C]列和[D]列执行[B]*0.03: 

cos(deg2  
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图 122. 列操作设定误差 

20.2.3 NDPlot 列操作支持的公式和运算 
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21 绘图设置 

21.1 画布大小的设置  

可以通过菜单 Canvas->SetCanvas 设置当前画布的大小。 

可以通过菜单 Settings->Global Environment 中 Canvas 标签

设置默认的大小 

 
图 123. 画布大小的设置 
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21.2 坐标轴尺寸、类型和数值范围设置 

21.2.1 坐标轴的激活区域 

 

粉色区域可单击或双击，修改坐标系的不同属性，如大小，位置，

尺寸。双击坐标刻度，或者从菜单 Axis 可以设置坐标轴的刻度字体，

网格，坐标轴标题。 

激活坐标轴后，坐标轴的 6 个点的区域左键按下并移动鼠标可以

改变坐标系尺寸，在坐标轴区域内左键按下并移动鼠标可以移动坐标

系。 
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图 124. 坐标轴激活区域 

21.2.2 修改坐标轴的数值范围，更改对数坐标/线性坐标 

可以通过展开左边的控制板（图上的 1）设置坐标范围和对数/

线性坐标，或者在画布上按下鼠标左键，画一个方形区域（图上的 2），

直观的选定坐标范围 

 
图 125. 修改坐标轴的数值范围 

新的坐标系： 
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图 126. 修改坐标轴的数值范围后绘图 

21.3 坐标轴的刻度（类型和字体）、标题、网格线的设置 

通过菜单 Axis 可以设置坐标轴的刻度（类型和字体）、标题、网

格等。 

 
图 127. 修改坐标系的标题、网格等 
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也可以通过双击刻度值区域调出 Axis Layer 窗口（红色区域）。 

 
图 128. 双击刻度值区域修改坐标系的标题、网格等 

 

加网格，改字体： 

 

图 129. 设置水平网格 
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图 130. 加网格、改字体后的结果 

可以用鼠标直接拖拽改变坐标轴的标题的位置。 

 
图 131. 改变坐标轴标题的位置 

21.4 图注的更改 

21.4.1  图注内容的更改 

(1)通过 data->manipulating data 菜单更改，直接修改

Annotation 
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图 132. 改变图注内容 

（2）直接在画布上双击图注，进行修改（ENDFB8.0） 

 

图 133. 双击图注改变图注 
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21.4.2 图注位置、字体、排列的更改 

（1）单击图注可将图注拖到画布上任意位置。 

 

图 134. 单击图注移动 

（2）修改图注排列方式。 

A．整体排列可以划分为 1-4 列 

 

图 135. Set Legend Stytle 



81 
核数据处理绘图客户端软件 NDPlot V0.98b 

B．独立排列可以任意拖动每一个图注 

 
图 136. 图注独立排列 

 

（3）Font->Legend Font 更改字体。 

 
图 137. 图注改变字体 
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21.4.3 图注的间距调整，以满足出版的要求 

1）从 legends 菜单对当前窗口进行更改 

 
图 138.改变图注间距 

2）从 settings 菜单保存全局默认变量 

 
图 139.保存全局变量 

以后打开软件，新的绘图将使用全局变量的间距。 

21.4.4 添加/删除文字 

添加文字，通过左面控制板的 Add 按钮 
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图 140. 添加文字 

修改字体：点中 new text，Font->text font 可以更改字体： 

 
图 141. 改变添加文字的字体 

 

删除增加的文字，点中 new text，Edit->Delete Text。 
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21.4.5  显示/隐藏图注 

可以通过 Data->Manipulating(ALT+D)来决定显示/隐藏图注 

 
图 142. 显示/隐藏图注 

 

对于实验数据，有时由于图注太多，可以通过菜单

Annotations->Hide/Show All Exp. Annotations 来显示隐藏实验数

据图注。 

21.5 曲线/数据点的隐藏/显示/删除、颜色和形状设置 

可以通过 Data->Manipulating(ALT+D)可以更改曲线/数据点颜

色和形状。 

 

图 143. 曲线/数据点的显示、隐藏、颜色和形状 

勾选 isPlotted 可以显示或者隐藏曲线/数据点。 

从菜单 Edit-》Delete hidden curves（points）可以永久删除

隐藏的数据点或者曲线。 
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22 绘图辅助功能 

22.1 Quick Choice 快速显示/隐藏曲线数据点 

路径：菜单->Quick Choice(ALT+Q)。 

反复勾选可以清楚看到曲线数据点的分布,如反复勾选

ENDFB8.0： 

 
图 144. 反复勾选显示数据形状（隐藏） 
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图 145. 反复勾选显示数据形状（显示） 
 

22.2 QuickChoice 的快速组操作 

可以用鼠标选定一组进行同时操作，点击组中任意一个图注，组

中所有的都将设置成勾选或者不勾选。 

 

图 146. 多组同时操作 

如上所示，实验数据全部被隐藏。 
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图 147. 多组同时操作（隐藏） 

刷新后： 

 
图 148. 刷新结果 
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23 NDPlot0.95 版以后增加的绘图顺序说明和效果 

23.1 绘图顺序修改 

路径：菜单 Data-》Manipulating Data（快捷键 Alt+D） 

 
图 149. 密集的蓝色数据点遮蔽了其它数据点 

如上图，蓝色数据点遮蔽了其它数据点，可以将其绘图顺序调整

成最先次序，默认的 order number 为 0，所以设成负数就是先绘制： 

 
图 150. 修改蓝色数据点的绘图顺序（最底层） 

结果如下： 
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图 
151. 修改蓝色数据点的绘图顺序的结果 

23.2 突出显示某条曲线 

为突出显示某条曲线（最后一个绘制，在最上层），将其设置为

所有 order number 中最大的一个数值，并设置颜色为亮红： 

 
图 152. 修改 order 和颜色 

结果如下： 
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图 153.突出显示某条曲线的效果 

NDPlot 最新版打开 NDD 格式时， EVAFILE 标记的自动给了 100

的 order number，对 C32 批量绘图的效果就是 C32 在最顶层。 

24 颜色循环（色轮）设置(固化某一评价库颜色) 

24.1 建立颜色循环 

      颜色循环是软件依次使用的颜色次序，同时支持固化评价库

的颜色。 

菜单：Setttings->Color Cycle： 
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图 154.建立颜色循环 

可以用 ann.filter 来固化评价库的颜色，建议加在色轮的末尾，

效果如下图： 
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图 155.建立颜色循环后的绘图 

24.2 恢复初始设置 

可以删除 ColorCycle.ini 来恢复初始设置。 

25 输出 JPG、PDF、PS、Word 图形 

25.1 复制图形到剪贴板 

菜单：Edit-》Copy Graph to clipboard（快捷键 CTRL + C） 

25.2 保存 JPG，BMP 

菜单：File-》Save picture 
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25.3 生成 PDF 

菜单：File-》Print（Ctrl+P），打印当前窗口或者 print all 打

印所有窗口 

选择 PDF 打印机（如 Acrobat PDF 打印机） 

25.4 生成 PS 文件 

打印，打印机选择 PS 打印机，勾上打印到文件。 

 
图 156. 打印 PS 文件 

 

保存类型：所有文件。 
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图 157. 保存 PS 文件 

25.5 生成 Word 

菜单：File-》Output Word。 

利用所有窗口产生 Word 文件。 

 
图 158. 输出 WORD 文件 
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25.6 产生 EMF 矢量图（支持 WORD、PPT） 

安装 VERY PDF DEMO EMF PRINTER（免费版），下载地址：

http://www.nuclear.csdb.cn/ndplot/mini-emf-printer.rar，为减

少白边（微软的 Word 也可以直接在 wrod 里剪裁 EMF 矢量图白边，非

常方便），可以将 canvas 尺寸设置成打印纸尺寸的整数倍。如 A4 纸

张的横向尺寸是 297mm*210mm,3 倍的尺寸是 891*630。 

 
图 159. 设置画布大小 

打印： 

 

图 160. 选择 EMF 打印机 
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选择相应的纸张尺寸，如 A4（默认） 

 
图 161. 选择纸张 

 

VERY PDF DEMO EMF PRINTER 免费版支持 A0, A1, A2,A3,A4,A5，

B4,B5。 

 
图 162.纸张尺寸 

免费版弹出如下窗口： 
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图 163.打印完成 

 

点确定后，出现如下 dos 窗口： 

 
图 164.DOS 窗口 

按任意键继续。输出文件在“E:\” 

效果如下，可无极放大： 
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图 165.矢量图结果 

修改 VeryPDF Mini EMF Printer 的 option.ini 可改变输出文

件位置： 

C:\Program Files (x86)\VeryPDF Mini EMF Printer 

v2.0\emf_printer_driver\option.ini 

 
图 166.INI 文件位置 
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图 167.修改 INI 

OutputFile=D:\out.emf，输出文件在 D:\ 

26 如何利用 PREPRO 加工本地的 PENDF 格式评价数据 

26.1 PREPRO 的使用 

NDPlot 使用 PENDF 格式的评价数据来处理角分布、能谱、双微

分截面。如果仅仅是截面，本地 ENDF 文件可以不必加工成 PENDF 格

式。 

路径：Utilities->Prepro。 
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图 168. 用 PREPRO 加工 PEDNF 文件 

26.2 将本地文件进行处理和绘图 

在 Data-》Connect to Evaluated lib 或者 Batch Ploting 菜单

中都可以将本地 PENDF 文件加入，如果仅仅是截面数据，可以使用

ENDF 格式的数据。 
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图 169. 加入本地 PEDNF 文件 

 

27 附加说明 

27.1 如何安装 ps 打印机 

PS 打印机可任意安装 windows 内含的 ps 打印机驱动，以 win10 

为例： 
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如下面的 PS 打印机： 

 

或者微软的 PS 打印机： 
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